Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
GolubinoeMoloko
25.11.2022 04:07 •
Информатика
Составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal
Показать ответ
Ответ:
Bluka23
21.07.2020 11:59
Program prog;
uses crt;
var
a,b,c,s,p:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);
if (a>0) and (b>0) and (c>0) then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s:0:3);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
milenohkaKiss6565
31.07.2022 21:34
Побудувати за логічною функцією комбінаційний пристрій на однотипних елементах 2АБО-НЕ і 2І-НЕ....
kasper121314
29.11.2021 02:13
Найдите максимально возможное количество цветов в палитре если известно что размер изображения 151 X151 для хранения этого изображения выделено 4 КБ памяти...
adilimanaliev03
21.08.2022 14:02
Вопрос не очень сложный. Перечислить и описать операции по редактированию текстового документа. Описать их выполнения...
danilru940Vova
15.03.2022 10:58
Как сделать цветок в PascalABC с 5 кругов Мне нужна код...
Тогжан11111111
01.07.2022 04:50
Что делать, если случайно нажал через файлы на установку приложения в установочном пакете, а когда вышел, то память на телефоне съелась,а файл то не скачался. Как вернуть...
Nikbatyr
18.12.2022 07:13
Складіть проект для побудови в одній системі координат графіків функцій у = 2*х + 60 і у = 4*х - 80. Використовуючи ці графіки, знайдіть наближене значення розв язку...
виктория123600
06.02.2020 14:34
Кто может сделать книгу на delphi, нужна...
KateKein
06.02.2020 14:34
1. являются ли алгоритмами ниже наборы команд? ответ поясните. а) 1. умножить а на 2 2. сложить а с 5 3. полученный результат разделить на 3. б) 1. сложить 5 и 2 2. полученный...
mankoyana
10.11.2022 16:36
Для какой логической операции результатом будет истина, если хотя бы один вход -истина? 1) логическое или 2) логическое и 3) логическое не 4) исключающее или с объяснением,...
ubfhbc
17.09.2022 13:11
Склавиатуры запрашивается любое целое число,а затем компьютер печатает таблицу умножения этого числа на числа от 1 до 10. написать программу на языке паскаль....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var
a,b,c,s,p:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);
if (a>0) and (b>0) and (c>0) then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s:0:3);
end;
end.