В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Zubactick
Zubactick
16.09.2021 14:11 •  Информатика

Составить программу. вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .

Показать ответ
Ответ:
natalyabuben0111
natalyabuben0111
20.09.2020 06:46
Uses crt;
var s:string;
i:integer;
l:boolean;   
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin 
if  (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')     
else Writeln('Нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота