В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
grishaeva79
grishaeva79
10.04.2022 23:40 •  Информатика

Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся»
Оценки по физике: 5 5 5 5 5 5 5 5 5
Оценки по информатике: 5 4 4 4 3 3

Показать ответ
Ответ:
mebelru
mebelru
14.10.2020 13:21

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int GradesInformatics,  GradesPhysikc;

   cout << "Введите количество оценок по информатике" <<endl;

   cin >> GradesInformatics;

   cout << "Введите количество оценок по физике" << endl;

   cin>> GradesPhysikc;

   int* Informatics = new int[GradesInformatics];

   int* Physicks = new int[GradesPhysikc];

   int Tmp = 0;

    cout << "Введите оценки по информатике" <<endl;

   for (int i = 0; i < GradesInformatics; ++i) {

       cin >> Informatics[i];

   }

   cout << "Введите оценки по Физике" <<endl;

   for (int i = 0; i < GradesPhysikc; ++i) {

       cin >> Physicks[i];

   }

   for (int i = 0; i < GradesInformatics + GradesPhysikc; ++i) {

       Tmp = Tmp + Informatics[i] + Physicks[i];

   }

   if (Tmp > 8) {

       cout << "Молодец " << endl;

   }

   else {

       cout << "Постарайся " << endl;

   }

   delete[] Informatics;

   delete[] Physicks;

}

Объяснение:

Код на с++

Так как в задании не указано,сколько всего оценок может быть,то спрашиваем это в рантайме у пользователя. Затем получаем эти оценки при двух циклов for. Потом складываем всё,что получилось в tmp и выводим ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота