Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
андрей2149
16.03.2021 17:26 •
Информатика
Составление алгоритма вычисление суммы всех целых чисел заданного отрезка программы
Показать ответ
Ответ:
SAIIIEK
08.10.2020 17:12
Program Nazvanie;
var
i, n, m: integer;
begin
write('Любое натуральное число: ');
readln(n);
for i:=1 to n do
begin
m:=m+i;
end;
writeln('сумма всех натуральных чисел не превышающих ',n,' - ',m);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
irisha190784
22.09.2021 14:52
Написать программу вычисления корней квадратного уравнения ах^2 + bx + c=0. Коэффициенты а, b, с вводятся с экрана. Программа должна вычислить как действительные, так и комплексные...
borshliba
09.02.2022 10:08
Всберкассу на трехпроцентный вклад положили s рублей. какой станет сумма вклада через n лет? надо решить с пост условием и параметром...
EnderDragon500
17.03.2023 00:38
Расшифровать слова. вот они: амнкеь,аскстеа,акжкин,секдиат,агубам....
Motya232
29.03.2021 11:04
Вопросов 1. Как рассчитать наработку встроенных циклов? 2. В чем сложность увеличения количества встроенных шлейфов? 3. Как представить данные в табличной форме? 4. Какие...
avanesyan20011
28.05.2020 08:06
Дан Массив D из 15 элементов, заполненный случайНЫМИ ЧИСЛами от 0 до 100. - сформируйте массив F, добавив в него все элементы меньше 45 и больше 15 из массива D.-Выведите...
I3eTePo4eK265
11.09.2020 14:55
Что такое диаграмма? •Графическое отображение числовых данных и соотношения между ними •Последовательность ячеек которая образует логическую цепочку •Внешнее оформление данных...
kotnapnewme123p04tz4
06.05.2023 08:08
Растрлык графиканын векторлык графикага караганда бр артыкшылыгы...
master204
27.01.2020 17:09
БЫСТРО У НАС СОР ИДЕТ ПО ИНФОРМАТИКЕ даю 31. ...
KATE270701
21.03.2022 09:00
выполнить задание 4 и задание 5...
ScHooLNick555
21.03.2022 09:00
процедуры состоит из слова procedure, за которым следует имя процедуры, которое используется для активации ее выполнения. Если у процедуры есть то они указываются после имени...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
i, n, m: integer;
begin
write('Любое натуральное число: ');
readln(n);
for i:=1 to n do
begin
m:=m+i;
end;
writeln('сумма всех натуральных чисел не превышающих ',n,' - ',m);
end.