Составьте программу для перевода из Килобайтов в Байты . Вспомните что 1КБ=1024 байт, значит, чтобы перевести в Килобайты в Байты, нужно указанное количество Килобайт умножить на 1024. Обязательно при выводе ответа указать единицы измерения. Сделайте скриншот программного кода и скриншот результата программы. Прикрепите.
Основные идеи современной информационной технологии базируются на концепции, согласно которой данные должны быть организованы в базы данных с целью адекватного отображения изменяющегося реального мира и удовлетворения информационных потребностей пользователей. Эти базы данных создаются и функционируют под управлением специальных программных комплексов, называемых системами управления базами данных (СУБД).
Увеличение объема и структурной сложности хранимых данных, расширение круга пользователей информационных систем привели к широкому распространению наиболее удобных и сравнительно простых для понимания реляционных (табличных) СУБД. Для обеспечения одновременного доступа к данным множества пользователей, нередко расположенных достаточно далеко друг от друга и от места хранения баз данных, созданы сетевые мультипользовательские версии БД основанных на реляционной структуре. В них тем или иным путем решаются специфические проблемы параллельных процессов, целостности (правильности) и безопасности данных, а также санкционирования доступа.
Целью этой работы является создать базу данных в СУБД ACCESS. Которая должна будет автоматизировать работу сотрудников книжного магазина.
Теоретическая часть
Базы данных и системы управления базами данныхБазы данныхПо упрощенному определению, база данных - это набор данных, которые используются системой. Обычно под данными подразумевают значения, хранящиеся в базе данных. Но сегодня данные могут быть песней, картинкой или видеороликом. Система управления базой данных - это программы, которые хранить, управлять и использовать наборы данных независимо от их формата. В более формальном определении система управления базой данных - это программное обеспечение, которое создает, поддерживает и использует базы данных. Примерами популярных крупных систем управления базами данных являются Oracle, Microsoft SQL Server и IBM DB2. Возможно, вы работали с небольшими системами управления базами данных, такими как Microsoft Access.
Большинство используемых сегодня баз данных попадают в категорию реляционных баз данных, которые организуют данные в виде набора связанных таблиц. Хотя данная книга нацелена на изучение именно реляционных баз данных, существуют и другие типы баз. К примеру, большинство старых систем использовали одноуровневые неструктурированные базы данных, в которых данные были расположены в одной большой таблице. Также существуют объектно-ориентированные, иерархические и сетевые базы данных.
Для изучения реляционных баз данных необходимо знать некоторые ключевые термины и понятия.
Таблица состоит из строк и столбцов. Каждая строка содержит данные об отдельном покупателе, тогда как столбцы содержат определенный элемент данных. Каждая ячейка в таблице содержит элемент данных, или одиночное данное. Строки также называются записями, а столбцы иногда называются полями. Каждая строка в таблице определяется столбцом или набором столбцов, которые являются уникальными. Если использовать термины теории баз данных, то уникальный идентификатор называется ключом. Таблица может иметь более одного ключа, но только один из них может быть выбран первичным ключом, который будет служить идентификатором для этой таблицы.
Реляционные базы данных следуют набору определенных правил, которые гарантируют целостность данных, хранимых в базе. Заметьте, что мы не использовали слово «корректность». Правила гарантируют лишь то, что данные не будут противоречивыми.
Существуют следующие типы моделей представления данных:
Иерархическая модель данных
Иерархическая база данных - первый предок всех баз данных. Ее название происходит от представления базы данных в виде древовидной иерархии, похожей на систему каталогов в компьютере. Самый известный подобного рода продукт под названием Information Management System (IMS, Информационная управляющая система) был разработан компанией IBM. IMS доминировал на рынке крупных баз данных с 1960-х до ранних 1990-х годов. Единственная проблема IMS заключалась в сложности ее использования. Для взаимодействия с базой данных требовался профессиональный программист. Несмотря на усилия IBM по сокращению сферы ее использования в пользу реляционных продуктов, IMS по-прежнему применяется в некоторых старых системах для управления большими базами данных, таких, например, которые используются в страховых компаниях. Компании по-прежнему используют IMS по четырем причинам. Во-первых, она дает возможность быстрого доступа к миллионам записей. Во-вторых, переход к реляционной системе может привести к временным перерывам в работе систем. В-третьих, такой переход потребует значительных финансовых затрат. В-четвертых, сложно проводить изменения в работе информационной системы в процессе ее работы.
A,S,n:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
n:=0;
While A<>0 do
Begin
S:=S+A mod 10;
n:=n+1;
A:= A div 10
End;
WriteLn('Sr = ',S/n);
End.
Var
A,S:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
While A<>0 do
Begin
if (A mod 10) mod 3 = 0 then S:=S+A mod 10;
A:=A div 10
End;
WriteLn('S = ',S);
End.
Var
A,m:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
m:=9;
While A<>0 do
Begin
if A mod 10 < m then m:= A mod 10;
A:=A div 10
End;
WriteLn('Min = ',m);
End.