В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MrShkololo
MrShkololo
10.12.2022 04:19 •  Информатика

Составьте программу для решения задачи. python Составьте программу для решения задачи.
Необходимо обклеить обоями стену длиной a м и шириной b м. Сколько будут стоить обои, если цена одного рулона k грн? Длина рулона обоев 10 м, а ширина 80 см.

Показать ответ
Ответ:
jojolili
jojolili
06.06.2023 12:03
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида

//PascalABC.Net

function NOD(A, B: integer): integer;
begin
    while A <> B do
        if A > B then A := A - B else B := B - A;
    NOD := A;
end;

procedure pNOD(A, B: integer; var NOD: integer);
begin
    while A <> B do
        if A > B then A := A - B else B := B - A;
    NOD := A;
end;

begin
    var a: Array of integer := (16, 32, 40, 64, 80, 128);
    var n := a[low(a)];
    for var i := low(a) to high(a) do
        pNOD(n, a[i], n);
   
    Writeln(n);
end.
0,0(0 оценок)
Ответ:
1939346
1939346
10.09.2022 11:40
В состав алфавита языка Паскаль входит:
  Символы для составления переменных-
                                                                латинские(строчные, прописные)
                                                                символ "_"
                                                                цифры (0..9)
  Символы разделители (пробельные символы)
  Составные символы - особенная группа символов, которая  
                                           воспринимаются компилятором как     
                                           один символ "<=", ":=",">=", "..", "//" "<>" "(*" "*)"
  Зарезервированные слова- слова, несущие определенное     
                                                    смысловое значение для компилятора
  Спец-символы- символы, которые предназначены для построения 
                               конструкций языка, в Паскале это:
                                                                             ' - + / * : ; = { } [ ] ( ) $ и т.п

  На самом деле их больше, но это основные.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота