В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
даня1003
даня1003
08.03.2021 07:28 •  Информатика

Составьте программу к следующей : ученик начал решать данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти .

Показать ответ
Ответ:
Wolf2002
Wolf2002
05.10.2020 16:06
Используется время одних суток.
var h1,min1,h2,min2,h,min,m:integer;
begin
write('h1, m1: ');
readln(h1,min1);
write('h2, m2: ');
readln(h2,min2);
m:=(h2*60+min2)-(h1*60+min1);
h:=m div 60;
min:=m mod 60;
writeln('h = ',h,' min = ',min);
end.

Пример:
h1, m1: 1 20
h2, m2: 3 15
h = 1 min = 55
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота