В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран. например 'a'< 'б', 'д'='д, 'я'> 'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов

Показать ответ
Ответ:
незнайка1183
незнайка1183
24.05.2020 23:18

а), б)

var a, b, c: char;

begin

  writeln('Введите 3 символа');

  readln(a, b, c);

  writeln('Результат сцепления: ', a+b+c);

  if a>b then writeln(a,'>', b);

  if a>c then writeln(a,'>', c);

  if a=b then writeln(a, '=', b);

  if a=c then writeln(a, '=', c);

  if a<b then writeln(a, '<', b);

  if a<c then writeln(a, '<', c);

  if b>c then writeln(b, '>', c);

  if b<c then writeln(b, '<', c);

end.

в)

var a, b: char;

begin

  writeln('Введите 2 символа');

  readln(a, b);

  if a>b then writeln(b,'  ', a);

  if a<b then writeln(a,'  ', b);

  if a=b then writeln(a,'  ', b);

end.

  

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота