В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу, которая будет определять положительное или отрицательное число ( программа c++) заранее )

Показать ответ
Ответ:
benblast
benblast
08.10.2020 12:53
#include<iostream>
using namespace std;
int x;
int main(){
cin>>x;
if(x>0) cout<<"Polozhitelnoye'';
else cout<<"Otritsatelnoye'';
return 0;}

Составьте программу, которая будет определять положительное или отрицательное число ( программа c++)
0,0(0 оценок)
Ответ:
twijuli
twijuli
08.10.2020 12:53
Усложним задание:
#include <iostream>
#include <string>
using namespace std;

template<typename T>
string sign(const T& x)
{
    return x < 0 ? "negative" : x == 0 ? "0" : "positive";
}

int main()
{
    cout << sign(-3.14f);
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота