В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Chekchik
Chekchik
29.07.2020 18:30 •  Информатика

Составьте программу, которая формирует массив из 12 случайных целых чисел , принадлежащих промежутку [-40; 40], и вычесляет сумму положительных чисел

Показать ответ
Ответ:
damiroid
damiroid
09.10.2020 06:02

#include <iostream>

#include <ctime>

using namespace std;

void main()

{

srand(time(NULL));

const int size = 12;

int arr[size];

int c = 0;

for (int i = 1; i <= size; i++)

{

 arr[i] = rand() % 80 + (-40);

 if (arr[i] % 2 != 0)

  continue;

 c += arr[i];

}

cout << c << endl;

system("pause");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота