В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zhazi9494e
zhazi9494e
31.08.2020 04:51 •  Информатика

Составьте программу, которая формирует массив из двадцати случайных целых чисел от -30 до 30 и подсчитывает количество четных элементов. на экран выводятся исходные массив и результат

Показать ответ
Ответ:
ggg289
ggg289
09.10.2020 15:39

var a:array[1..20] of integer;

i,k: integer;

begin

write('Массив: ');

for i:=1 to 20 do

begin

a[i]:=random(61)-30;

if a[i] mod 2 = 0 then k:=k+1;

write (a[i]:3,' ')

end;

writeln;

write('Количество четных элементов ',k)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота