Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nastya19831507
14.10.2022 00:18 •
Информатика
Составьте программу, которая находит произведение цифр заданного четырехзначного числа
Показать ответ
Ответ:
krnshlpn
05.10.2020 03:56
Var a, n, s: integer;
begin
read(a);
s := 1;
while a > 0 do
begin
n := a mod 10;
s := n * s;
a := a div 10;
end;
write(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Viki5776766
25.09.2022 10:44
Паскаль нужно было написать такую программу: 1) площадь треугольника корень кв. из p(p-a)(p-b)(p-c), где p=a+b+c/2 написал программу следующим образом: program abd; var a,b,c; integer;...
rasaka123
02.09.2020 17:27
1) определяет первое требование для создания программы; 2) определяет второе требование для создания программы; 1 3) определяет третье требование для создания программы;...
Vivitek31
03.03.2021 11:41
Выполните последовательность действий 1) задумайте любое трехзначное число 2) умножьте задуманное число на 3 3) к ответу прибавьте 9 4) к ответу прибавьте 15 5) из ответа вычтите...
gobon1337
03.03.2021 11:41
Сканируется цветное изображение размером 43,18×43,18 дюйм. разрешающая сканера — 1200×1200 dpi, глубина цвета — 16 бита. какой информационный объём будет иметь полученный графический...
qwer54321asdfrewq
03.03.2021 11:41
Запишите примеры любых данных, которые можно представить в виде массива. основное условие: массив должен состоять не менее чем из 15-ти элементов. например, массив темр будет хранить...
mariyasidorova1
13.06.2021 04:41
Создайте несколько сферических панорам любого помещения, например, школьного кабинета, библиотеки, столовой, школьного зала....
ваня1340
01.05.2023 04:43
Написать программу на С# для решения следующей задачи: в матрице D(10,10) найти строки с наибольшей и наименьшей суммой элементов и вывести на печать данные строки и суммы....
christihhh75
14.04.2023 17:03
Напишите программу, которая получает три числа -рост трёх спортсменов, и выводит сообщение «По росту. », если они стоят по возрастанию роста, или сообщение «Не по росту!», если...
justnero
08.12.2022 16:50
Напишите наибольшее число х, для которого ложно высказывание: HE (x x 48) или (х нечётное).48475049Другое:...
Лес333
08.12.2022 16:50
Архиватор программаларында архивациялау қалай жүзеге асады...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
read(a);
s := 1;
while a > 0 do
begin
n := a mod 10;
s := n * s;
a := a div 10;
end;
write(s);
end.