Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vabyn
20.08.2022 17:15 •
Информатика
Составьте программу, которая находит сумму чисел, обратных числам целым числам от 1 до n, т.е. s=1/1+1/2+1/3++1/n.
Показать ответ
Ответ:
betextinaanast1
08.10.2020 14:28
Program abc;
var
n, i: integer;
s: real;
begin
write('Введите количество чисел: ');
readln(n);
for i := 1 to n do
s := s + 1 / i;
write('Сумма обратных чисел = ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dmitryparshin
08.04.2023 04:26
Что такое оптический привод в компьюторе...
MaGaFaYa
08.04.2023 04:26
Сообщение занимает 4 страницы по 40 строк и содержит 7200 байтов информации. сколько символов в строке, если при составлении этого сообщения использовали 8-битное кодирование?...
ника2757
08.04.2023 04:26
Впитоне напишите программу, которая определяет, является ли заданная строка (возможно, содержащая пробелы) палиндромом, то есть верно ли, что она после удаления пробелов...
lilililiza
26.11.2021 04:29
Склавиатуры вводится числа . завершение ввода - число 0. найдите сумму введённых чисел....
superakkroyale2
26.02.2021 13:48
Присвоить к переменной s значение года световой длинны.световой год (свет проходит 365 суток =300км/с)...
wjwjwjeuei
15.07.2021 14:13
Сопоставь объекты электронных таблиц с их названиями: 1. d4: f7 2. $r$2/25 3. b102 4. g3+4*k17 5. 52a 6. mиh(a2: f4) а) адрес ячейки б) диапазон ячеек в) формула с относительными...
89195188243aMils
06.09.2022 08:36
Получить все расстановки шести книг разных авторов...
111леся199
06.09.2022 08:36
Перед вами гипотетический процессор с 32 разрядной адресацией. при каждой операции вводятся или извлекаются 32 бита данных. ответьте на нижеследующие вопросы. ответ дать...
МиланаТрошина
05.10.2021 07:20
Номер (вправа) 1, 1 и 3 пункт.Розгляньте наскельний малюнок...Знайдiть в iнтернетi......
artiom726
03.06.2023 16:04
Формальным языком является язык ......
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
n, i: integer;
s: real;
begin
write('Введите количество чисел: ');
readln(n);
for i := 1 to n do
s := s + 1 / i;
write('Сумма обратных чисел = ', s);
end.