В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ника2757
ника2757
08.04.2023 04:26 •  Информатика

Впитоне напишите программу, которая определяет, является ли заданная строка (возможно, содержащая пробелы) палиндромом, то есть верно ли, что она после удаления пробелов читается одинаково слева направо и справа налево. входные данные входная строка – последовательность символов, возможно, содержащая пробелы. выходные данные программа должна вывести слово 'yes', если введённая строка – палиндром, и слово 'no', если она не является палиндромом. примеры входные данные ka za k выходные данные yes входные данные kaza n выходные данные no сдать:

Показать ответ
Ответ:
На примере в этой   program z1; uses crt; const st1='ма'; st2='ма'; var str: string; i,k: integer; begin write('введите строку: '); readln(str); for i: =1 to length(str) do if (st1=copy(str,i,2)) or (st2=copy(str,i,2)) then k: =k+1; writeln(k); end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота