В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
digrigoreva61
digrigoreva61
18.04.2020 01:48 •  Информатика

Составьте программу,которая определяет,сколько слагаемых должно быть в сумме 1+2+3+ сумма оказалась: а)больше 20; б)больше заданного числа n;

Показать ответ
Ответ:
paa050403
paa050403
25.05.2020 06:43

program ddd;
var i,n,s,k:integer;
begin
write('Введите n: ');
readln(n);
s:=0; k:=0;i:=1;
while s<=n do
begin
s:=s+i;
writeln(i);
inc(i);
inc(k);
end;
writeln('Необходимо ',k,' слагаемых; сумма равна ',s );
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота