В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
михалыч676
михалыч676
30.09.2020 21:56 •  Информатика

Составьте программу, которая определяет, является ли данное натуральное число простым, и выводит на экран соответствующее сообщение: «да» либо «нет».

Показать ответ
Ответ:
Книжнаябабочка
Книжнаябабочка
06.06.2020 21:21

program xxx;

var k, d, n : integer;

      pr : boolean;

begin

  writeln('Введите число k=');

  readln(k);

  d:=2;

  n:= k div 2;

  pr:=false;

  while (d<=n) and not(pr) do

     if k mod d = o then pr:=true else d:=d+1;

  if pr then writeln (k, '- нет, число не простое') else writeln (k, ' да,число простое');

   readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота