Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Tori163
27.10.2020 14:31 •
Информатика
Составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие
Показать ответ
Ответ:
viktoria050504
25.06.2020 07:29
const
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
zhivotkhanova95
26.02.2023 16:42
Постройте ориентированный граф(рисунок) автомата Мура. Автомат, принимая на входе монеты 10; 15 и 20 коп., выдает сигнал П, если значение текущей сум-мы опущенных монет кратно...
yusdanila
15.03.2022 01:39
C#: Описать структуру с именем TRAIN, содержащую следующие поля: • название пункта назначения; • номер поезда; • время отправления. Написать программу, выполняющую следующие...
Olesya11111111111111
11.01.2020 03:46
Розмір масиву 20тип даних цілийВпорядкувати за зростанням другу половину масиву(с++)...
Masha15122006
02.03.2021 23:59
Найти количество элементов массива А(10), значения которых лежат между средним арифметическим элементов массива В(10) и средним геометрическим элементов массива С(10)ответ...
guardian009888
08.06.2021 12:41
Здача С++ Точка и выпуклый многоугольник Для заданных выпуклого многоугольника и точки нужно определить, принадлежит точка многоугольнику или нет. Формат входных данных Входные...
Deva0revolution
26.04.2022 17:10
Задача С++ Расстояние от точки до отрезка Необходимо найти расстояние от точки до отрезка. Формат входных данных Шесть целых неотрицательных чисел, не превышающих 10000 -...
lanamuradyamu
31.08.2022 16:21
Дан список чисел. выведите значение наибольшего эле- мента в списке, а затем индекс этого элемента в списке. если наибольших элементов несколько, выведите индекс первого из...
kirillyamont2
13.07.2021 10:54
Главная мысль рассказа всенощное бдение...
nastich1
13.10.2021 10:51
1 абзац Начало( Кто такой герой )2 абзац про 1 качество3 абзац про 2 качество 4 абзац заключение .По легенде о Данко тема Кто такой герой...
vxtrxxx
02.10.2020 14:35
Ввожу с клавиатуры целое число. Пусть это число равно Y. На экране вывода получаю последовательно выведенные числа от 1 до Y, причем только нечетные. Например: ввожу 14, получаю...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.