Составьте программу, которая стронг круговую диаграмму
иллюстрирующую сдачу
каменов группой студентов (10
Во студентов слапи на 4, 15 студентов сдали на 5.35 %
студентов сдали на 6. 10-%
студентов сдали на 7, 10-% студентон сдали на 8, 10 %
студентов сдали на 9 и 10% студентов сдали на 10.0
var
n, i, aon_i, k: integer;
f: boolean;
function AmountOfNumbers(n: integer): integer;
var
s: integer;
begin
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10;
end;
AmountOfNumbers := s;
end;
begin
readln(n);
for i := 0 to n do
begin
f := true;
aon_i := AmountOfNumbers(i);
for k := 2 to 9 do
f := f and (aon_i = AmountOfNumbers(k * i));
if f then writeln(i);
end;
end.
Объяснение: