В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ясмина1604
Ясмина1604
23.06.2022 14:41 •  Информатика

Составьте программу которая в случае если данное число положительное прибавляет к несу 3, а если ттрицательное вычисляет 3

Показать ответ
Ответ:
keggen
keggen
20.12.2021 11:09
1. 40Мб = 40960 Кб. Пусть V1 = 128 Кб/c, а V2 = 64Кб/c (по условию), то S1=20480Кб, а S2, соответственно, тоже 20480Кб. Отсюда t1= S1/V1 или t1=20480Кб/128Кб/с=160с. Соответственно t2=20480Кб/64Кб/c=320c. Отсюда t=160+320=480c или 480с/60с=8минут.
2. 19минут = 1140 секунд. Тогда размер файла составляет 17Мб*1140с=19380Мб или,примерно, 19Гб.
Т.к. 1Гб не оплачивается, то 19-1=18Гб трафицируются. Тогда 18Гб=18432Мб.
Цена составляет 18432Мб*0,06 рублей = 1106 рублей. 
P.S. Не дешевый, однако, провайдер. :D
0,0(0 оценок)
Ответ:
Нezнaйка
Нezнaйка
24.01.2023 05:37
Рассмотрим случай, когда число клеток по вертикали n четное. В этом случае каждая пара горизонталей доски содержит ровно m клеток (m - число клеток доски по горизонтали). Тогда общее число черных клеток равно m*n/2.
При нечетном n к рассмотренным горизонтальным строкам добавляется еще одна - нечетная, конфигурация которой совпадает с первой (нечетной) горизонталью.
Если клетка в левом нижнем углу первой горизонтали черная, то количество черных клеток в ней можно определить как сумму результата целочисленного деления количества клеток по горизонтали на два и остатка от этого деления. В результате приходим к следующей формуле:
k=\begin {cases} \frac{mn}{2}, \ n \, mod \, 2=0 \\ \frac{m(n-1)}{2}+ (m \, div \, 2)+(m \, mod \, 2), \ n \, mod \, 2=1 \end {cases}

Ниже представлен текст программы на языке Pascal.ABC.NET

var
  m, n: integer;

begin
  Write('Введите количество горизонталей на доске: ');
  Readln(n);
  Write('Введите количество вертикалей на доске: ');
  Readln(m);
  if (n mod 2) = 0 then Writeln('Черных клеток на доске- ', m * n / 2)
  else Writeln('Черных клеток на доске- ', m * (n-1) / 2 + (m div 2) + (m mod 2))
end.

Тестовое решение:

Введите количество горизонталей на доске: 8
Введите количество вертикалей на доске: 7
Черных клеток на доске- 28
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота