Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vladdobryj071
11.02.2022 18:15 •
Информатика
Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Показать ответ
Ответ:
amina090806
03.10.2020 07:49
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
0,0
(0 оценок)
Ответ:
ponomareva1947
03.10.2020 07:49
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
0,0
(0 оценок)
Популярные вопросы: Информатика
Зайчуля2004
21.06.2020 13:59
Подскажите, как решить задачу по информатике? Питон Ввести с клавиатуры координаты двух точек (А и В). Вычислить длину отрезка А и В. Формат входных данных : В первой...
лолпа
15.07.2021 06:31
вписать в таблицу истинности значения...
Veranda11
17.04.2021 19:16
последовательность натуральных чисел от 8 до 80 невключительно посчитать сумму элементов стоящих на четных местах в противном случае определить количество элементов...
QuAtTro271
03.08.2021 21:41
Нужно составить блок схему с использованием счетчиков и/или флагов. В целочисленном массиве A[N] каждый элемент заменить количеством единиц в его двоичном представлении....
AlexGadget1337
07.03.2020 10:42
Кодирования графических изображений...
natali1712
29.07.2020 00:18
кестеде жүйелік блоктың артқы панелінде орналасқан негізгі порттар берілген...
maxmax6
13.05.2023 10:15
о 1. Сведения об объектах окружающего нас мира это:1. информация2. объект3. предмет4. информатика2. Информацию, изложенную на доступном для получателя языке называют:1....
Minimuux
14.09.2022 08:28
Що мінералізує органічні речовини? ответ нужен в течении 3 минут...
Poniy11
05.03.2021 16:27
1.what is mother tongue?(explain) 2.Translate a)responsibility b) moody c) to have in common d) To earn 3. Complete the sentences with adjectives 1. Someone who doesn“t...
маг122
23.02.2021 14:47
М ма мат мате матем матема математ математи математик математика...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497