В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Artem19092002
Artem19092002
07.03.2020 14:39 •  Информатика

Составьте программу , которая заполняет массив случайными целыми числами в диапозоне от 1 до 100 , затем меняет местами наименьший четный элемент с наибольшим нечетным элементом

Показать ответ
Ответ:
ненадамине
ненадамине
26.05.2020 12:23

Program Pr1;
uses crt;
var mas:array[1..10] of integer;
i,max,min,a,b:integer;
Begin
clrscr;
max:=0;
min:=150;
randomize;
for i:=1 to 10 do mas[i]:=1+random(100);
for i:=1 to 10 do write(mas[i]);
for i:=1 to 10 do begin if (mas[i] mod 2=0) and (mas[i]>max) then begin
max:=mas[i];
a:=i;
end;
if (mas[i] mod 2=0) and (mas[i]<min) then begin
min:=mas[i];
b:=i;
end;
end;
i:=mas[a];
mas[a]:=mas[b];
mas[b]:=i;
writeln();
for i:=1 to 10 do write(mas[i]);
end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота