В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kris15kim
Kris15kim
16.09.2022 02:23 •  Информатика

Составьте программу, которая заполняет массива а [1..8] соучайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и суумму элементов массива с нечетными значениями

Показать ответ
Ответ:
Dfh32
Dfh32
29.07.2020 13:55
Program prog;
var a: array [1..8] of integer;
    k,s,i: integer;

begin
randomize;

for i:=1 to 8 do
begin
a[i]:=random(10)+1;
writeln('a[',i,'] = ', a[i]);
if a[i] mod 2 = 0 then
k:=k+1
else
s:=s+a[i];
end;
writeln;
writeln('Kolichestvo chetnyh k = ', k);
writeln('Summa nechetnyh S = ', s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота