В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kamila267
kamila267
24.01.2022 18:34 •  Информатика

Составьте программу, определяющую, лежит ли точка с указанными координатами x, y на окружности радиуса r с центром в начале координат. program frankenstein; var x,y,r: integer; begin write('введите координату x: '); readln(x); write('введите координату y: '); readln(y); write('введите длину радиуса r: '); readln(r); if (sqr(x)+sqr(y))=r then writeln('точка лежит на окружности! ') else writeln('точка не лежит на окружности! '); end. почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! где я ошибся?

Показать ответ
Ответ:
365282n
365282n
25.06.2020 13:09
R^2
Var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=sqr(r)  then 
writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота