В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Strong996
Strong996
05.12.2022 16:33 •  Информатика

Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg, 4 - ctg). составить программу, которая по введенному номеру n выполняет то или иное действие над числами x и y.

Показать ответ
Ответ:
yasuga
yasuga
08.07.2020 01:44
var
  n: integer;
  x, y: real;

begin
  readln(n, x, y);
  case n of
    1: writeln('sin(', x, ') = ', sin(x), #13, 'sin(', y, ') = ', sin(y));
    2: writeln('cos(', x, ') = ', cos(x), #13, 'cos(', y, ') = ', cos(y));
    3: writeln('tg(', x, ') = ', tan(x), #13, 'tg(', y, ') = ', tan(y));
    4: writeln('ctg(', x, ') = ', 1 / tan(x), #13, 'ctg(', y, ') = ', 1 / tan(y));
    else
      writeln('Null');
  end;
end.
Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. три
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота