В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
mintgirl
mintgirl
07.10.2020 15:16 •  Информатика

Составьте программу построения графика зависимости y=sin4x/sinx на отрезке [-20,20]. Установите начало системы координат в точке (400,300). Участки графика с положительными значениями функции нарисуйте красным цветом, а участки с отрицательными значениями функции - синим цветом.

Показать ответ
Ответ:
sakds
sakds
07.11.2020 04:16

#include <iostream>

#include <time.h>

#include <stdio.h>

using namespace std;

int main()

{

   srand(time(NULL));

   int mas[100][100] = {};

   int side;

   cout << "Введите размер стороны квадратной матрицы: ";

   cin >> side;

   for (int i = 0; i < side; i++)

   {

       for (int j = 0; j < side; j++)

       {

           mas[i][j] = 10 + rand() % (99 - 10 + 1);

           cout << mas[i][j] << " ";

       }

       cout << endl;

   }

   int max = mas[0][0];

   int max_ind_i = 0;

   int max_ind_j = 0;

   int min = mas[0][0];

   int min_ind_i = 0;

   int min_ind_j = 0;

   for (int i = 0; i < side; i++)

   {

       for (int j = 0; j < side; j++)

       {

           if (max < mas[i][j])

           {

               max = mas[i][j];

               max_ind_i = i;

               max_ind_j = j;

           }

           if (min > mas[i][j])

           {

               min = mas[i][j];

               min_ind_i = i;

               min_ind_j = j;

           }

       }

   }

   cout << "Максимум: " << max << " \nИндексы: " << max_ind_i << " " << max_ind_j << "\nМинимум: " << min << " \nИндексы: " << min_ind_i << " " << min_ind_j;

}

Объяснение:

Максимальный размер массива - 100 на 100

#include <iostream> // Библиотека ввода - вывода

#include <time.h> // Библиотека для работы со временем

#include <stdio.h> // Библиотека, содержащая функцию рандома

using namespace std; // Пространство имён

int main()

{

   srand(time(NULL)); // При каждом запуске программы будут новые псевдослучайные числа

   int mas[100][100] = {}; // Двумерный массив 100 на 100, заполненный нулями

   int side; // Переменная, хранящая сторону квадратной матрицы

   cout << "Введите размер стороны квадратной матрицы: "; // Вывод сообщения в консоль

   cin >> side; // Вводим сторону матрицы с клавиатуры

   for (int i = 0; i < side; i++) // Цикл для заполнения и вывода массива

   {

       for (int j = 0; j < side; j++) // Цикл для заполнения и вывода массива

       {

           mas[i][j] = 10 + rand() % (99 - 10 + 1); // Заполнение двумерного массива псевдослучайными числами в диапазоне [10, 99]

Формула: a + rand() % ( b - a + 1)

           cout << mas[i][j] << " "; // Выводим элемент массива

       }

       cout << endl; // Переносим на следующую строку (для красивого вывода)

   }

   int max = mas[0][0]; // Максимум = первому элементу массива

   int max_ind_i = 0; // Индекс max  i = 0

   int max_ind_j = 0; // Индекс max j = 0

   int min = mas[0][0]; // Минимум = первому элементу массива

   int min_ind_i = 0; // Индекс min i = 0

   int min_ind_j = 0; // Индекс min j = 0

   for (int i = 0; i < side; i++) // Цикл для прохода по всем элементам массива

   {

       for (int j = 0; j < side; j++) // Цикл для прохода по всем элементам массива

       {

           if (max < mas[i][j]) // Ищем максимум в массиве

           {

               max = mas[i][j]; // Присваиваем переменной max значение, которое оказалось больше ее

               max_ind_i = i; // Запоминаем индекс

               max_ind_j = j; // Запоминаем индекс

           }

           if (min > mas[i][j]) // Ищем минимум в массиве

           {

               min = mas[i][j]; // Присваиваем переменной min значение, которое оказалось меньше ее

               min_ind_i = i; // Запоминаем индекс

               min_ind_j = j; // Запоминаем индекс

           }

       }

   }

   cout << "Максимум: " << max << " \nИндексы: " << max_ind_i << " " << max_ind_j << "\nМинимум: " << min << " \nИндексы: " << min_ind_i << " " << min_ind_j; // Выводим ответ

}

0,0(0 оценок)
Ответ:
flora21345
flora21345
27.07.2022 18:48

Я думаю, что в будущем компьютеры станут безвредными для людей и окружающей среды. Их вид усовершенствуется до человеческого. Они будут расти вместе с хозяином (хозяйкой), хотя и смогут трансформироваться (от 1 см до бесконечности в длину и в толщину, а также в обычный компьютер или ноутбук). Причем, если вы идЈте поздно вечером домой, и боитесь бандитов, можно будет задать программу модифицирования, например в собаку. Или, допустим, Вы не считаете удобным ходить в школу с другом-компьютером, и тогда Вы сможете превратить его в какой-либо предмет или животное. У него будут такие же интересы, как и у их владельца, с ним можно будет свободно разговаривать, ходить куда-нибудь, и т. д. Это будет не человек и не робот, это будет компьютер. Питаться он будет не человеческой едой, не электричеством, а солнечным зарядом, причЈм, если кончится энергия, он сможет на автоматике завершить заданную ему задачу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота