В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Vanilingus
Vanilingus
24.05.2021 14:06 •  Информатика

Составьте программу, позволяющую проверить правописание "жи" и "ши" в строке s. выведите на экран количество допущенных ошибок и исправленную строку.

Показать ответ
Ответ:
АкадемеG
АкадемеG
17.09.2020 12:07
Var
b,i:integer;
S:string;
Begin
Readln(S);
b:=0;
For i:=1 to length(s) do 
if i<length(s) then begin
if (s[i]='ж') or (s[i]='ш') then if s[i+1]='ы' then begin s[i+1]:='и'; b:=b+1; end;

End;
Writeln(b);
Writeln(s);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота