В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
slaviktaran00
slaviktaran00
20.09.2022 11:45 •  Информатика

Составьте программу решения квадратного уравнения ax(во второй степени) + bx + c = 0. коэффициенты a,b,c введите с клавиатуры. выведите на экран значение корней x1,x2, если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "нет корней" , если уравнение не имеет корней. составьте программу на уровне 8 класса.

Показать ответ
Ответ:
bavara89
bavara89
09.07.2020 12:26
var
  a, b, c: real;

begin
  readln(a, b, c);
  if (sqr(b) - 4 * a * c < 0) then
    writeln('Нет решений')
  else
    if (sqr(b) - 4 * a * c = 0) then
      writeln('x = ', (-1 * b) / (2 * a))
    else
    begin
      writeln('x1 = ', (-1 * b + sqrt(sqr(b) - 4 * a * c)) / (2 * a));
      writeln('x2 = ', (-1 * b - sqrt(sqr(b) - 4 * a * c)) / (2 * a));
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота