В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
IgnatBakaev
IgnatBakaev
21.02.2020 20:42 •  Информатика

Составьте программу(в паскале), которая заполнит массив a[1..16]случайными целыми числами в диапазоне от -20 до 20, выводит на экран исходный массив, затем преобразовывает его, увеличивая в 2 раза все числа,кратные 5, а остальные уменьшает на 10. затем выводит на экран преобразованный массив.

Показать ответ
Ответ:
ILLNNXSI
ILLNNXSI
09.10.2020 11:13

const n=16;

var a:array [1..n] of integer;

i:integer;

begin

for i:=1 to n do a[i]:=random(41)-20;

writeln('Исходный массив: ');

for i:=1 to n do write(a[i]:5);

writeln;

for i:=1 to n do

if a[i] mod 5 = 0 then a[i]:=a[i]*2 else a[i]:=a[i]-10;

writeln('Преобразованный массив: ');

for i:=1 to n do write(a[i]:5)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота