В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bbcc2
bbcc2
02.12.2020 12:28 •  Информатика

Составьте программу заполнения массива из ста чисел, со случайными значениями из диапазона от -20 до 20. посчитайте в этом массиве количество положительный и отрицательных чисел.

Показать ответ
Ответ:
марго170
марго170
03.10.2020 07:41
Const n=100;
var x : array[1..n] of integer;
   i,k1,k2 : integer;
begin
Randomize; 
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=random(41)-20; 
  write(x[i],' ');     
 end;
 writeln;
for i:=1 to n do
 begin
 if x[i]<0 then k1:=k1+1;
 if x[i]>0 then k2:=k2+1;
 end;
writeln('k1=',k1,'  k2=',k2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота