В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ivanna1111111
Ivanna1111111
12.02.2023 20:28 •  Информатика

Составьте программу заполнения массива не используя клавиатуру, числами 1, -3, 5, -7, 9, -11, 13, -15. в питоне , если можно то не сильно сложно

Показать ответ
Ответ:
reopla
reopla
07.10.2020 00:37
# coding: utf-8
list = []  # создаём пустой лист
flag = 0  # переменная, которая будет чередоваться
for i in range(1, 16, 2):  # диапазон от 1 до 15 с шагом в 2 числа
    if flag == 0:  # когда переменная равна 0 пишем положительное число
        list.append(i)
        flag = 1
    else:  # иначе отрицательное
        list.append(-i)
        flag = 0
print(list)  # выводим результат на экран



Первую строку можно не писать.



Код без комментариев:

list = []
flag = 0
for i in range(1, 16, 2):
    if flag == 0:
        list.append(i)
        flag = 1
    else:
        list.append(-i)
        flag = 0
print(list)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота