Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nastysh20011
01.06.2021 18:38 •
Информатика
Создать программу, которая выводит на экран простые числа в диапазоне от 2 до 1000. (число называется простым, если оно делится только на 1 и на само себя без остатка; причем числа 1 и 2 простыми не считаются).
Показать ответ
Ответ:
авлвк5
01.07.2020 21:54
var a, i:integer;
procedure del(i:integer; var a:integer);
var j :integer;
begin
a:=0;
for j:=1 to i do
if i mod j = 0 then inc (a)
end;
begin
writeln;
for i:=2 to 1000 do
begin
del(i,a);
if a=2 then write (i, ' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
YDA2007
25.11.2021 17:09
До ть будь ласка АЛГОРИТМ ДУЖЕ ТРЕБА ВСЕ НА ФОТО...
Galiavey370
03.01.2023 23:38
Напишите программу, которая определяет, является ли переданное ей натуральное число простым (простое число делится только на 1 и само на себя). ОБЯЗАТЕЛЬНО СЕЛАТЬ...
SergeGu
25.12.2021 09:48
Используя диаграмму Венна, Сравните реляционные, иерархические и сетевые базы данных....
Lenika2len
03.12.2022 08:07
Постройте таблицы истинности для следующих логических выражений: 1. F=¬A&Bv¬B 2. F=(AvB)&¬A 3. F=XvY&¬X 4. F=X&¬(YvX)...
akonbkaru
29.12.2022 17:47
, как можно быстрее ,...
Aleqs2005
21.09.2020 13:41
ответить на вопросы: 1) какое из свойств дождевых червей было использовано при строительстве подводных лодок? 2) эхолокация пространственной ориентации, при которого...
45087
21.09.2020 13:41
Как найти угол выпуклого n- угольника , если известно, что все его углы равны...
wochdudj
21.09.2020 13:41
Обьясните как вы понимаете слова лиск: ты навсегда в ответе за всех кого приручил...
жироввадим
21.09.2020 13:41
Распредели слова по столбикам. в первый записывай слова с орфограммой звука в приставке.во второй записывай слова с орфограммой в корне.в третий-с орфограммой в суфиксе....
darjaborisenko
21.09.2020 13:41
Решите систему методом подстановки х+2у=1 ху=-1...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
procedure del(i:integer; var a:integer);
var j :integer;
begin
a:=0;
for j:=1 to i do
if i mod j = 0 then inc (a)
end;
begin
writeln;
for i:=2 to 1000 do
begin
del(i,a);
if a=2 then write (i, ' ');
end;
end.