В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dimadenisen
dimadenisen
31.05.2022 22:34 •  Информатика

Спрограммированием ( pascal ). дан массив случайных целых чисел d из промежутка [0; 10], состоящий из 10 элементов. составить программу вычисления суммы трех элементов. в качестве подпрограммы оформить вычисление суммы трех последовательно расположенных элементов массива с номерами от k до m: d[1], d[2], d[3], d[3], d[4], d[5], d[4], d[5],d[6].

Показать ответ
Ответ:
Const
  n = 10;

var
  D: array[1..n] of integer;

function Sum3(k: integer): integer;
begin
  Sum3 := D[k] + D[k + 1] + D[k + 2]
end;

var
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin D[i] := Random(11); Write(D[i]:3) end;
  Writeln;
  Writeln('Сумма D[1]..D[3]: ', Sum3(1));
  Writeln('Сумма D[3]..D[5]: ', Sum3(3));
  Writeln('Сумма D[4]..D[6]: ', Sum3(4))
end.

Тестовое решение:
Элементы массива
  2  1  5  9 10  2  9  7  2  1
Сумма D[1]..D[3]: 8
Сумма D[3]..D[5]: 24
Сумма D[4]..D[6]: 21
0,0(0 оценок)
Ответ:
azilhan1
azilhan1
17.07.2020 10:51
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 uses crt; const n=10; var a:array[1..n] of integer;     i,k,k0:integer;     s:real; begin  clrscr;   writeln('Массив :');    for i:=1 to n do     begin      write(i,' = ');       read(a[i]);     end;     k:=1;   for i:=1 to n do    if a[i]<0 then     begin      s:=s+a[i];      inc(k);     end    else      begin       if a[i]>0 then       inc(k0);      end;   s:=s/k; writeln;   if (k=1) and (k0=0) then    writeln('Положительных или отрицательных элементов в массиве нет,среднее ариф-ское = 0')   else    writeln('Среднее ариф-ского отрицательных элементов массива =',s:0:2);      readkey; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота