Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
LI100K
25.02.2023 11:52 •
Информатика
Сработой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Показать ответ
Ответ:
poliaaaaaa
03.10.2020 09:21
A) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
fursatana0
09.09.2021 11:02
Установи соответствие. база данных,поле,запись. 1)содержит информацию обо всех свойствах одного обьекта таблицы 2)содержит информацию об одном свойстве всех обьектов таблицы 3)структуированная...
u95macsalinaанна
08.01.2020 07:06
Составьте фрагмент применения лямбда-выражения на основе произведения...
strees1
21.03.2020 09:32
Практическое задание. Указать, по какому запросу будут выведены Планеты, чья масса не превосходит 100´1024кг и не меньше 2´1024кг и имеющие спутники. a. Масса= 100´1024 OR Масса...
геометрия64
11.06.2020 04:15
Hаписати програму яка дозволяє вводити числа до тих пір доки не буде введено 0. У введеній послідовності визначити кількість додатних, елементів та середне значення. Результати...
lissasalvatore
04.03.2022 04:09
На Питоне ! Давайте напишем программу, которая сдвинет список spisok следующим образом: Для этого, с функции pop() будем удалять первый элемент из списка, а затем добавлять его...
mashashhukina
20.10.2021 20:50
Алгоритм получает на вход натуральное число N 1 и строит по нему новое число R следующим образом: 1) Если исходное число кратно 2, оно делится на 2, иначе из него вычитается 1....
vyzgavalja1956
25.02.2020 20:53
Нужна формула Ексель Надо вычислить *количество заключённых на 100тыс чел*...
nastyakopylova7
18.10.2020 05:11
C++ На плоскости заданы два квадрата координатами левого верхнего угла и длинами сторон. Определить, пересекаются ли они. Значения вводить в диалоге, иметь возможность повторного...
katka1999
03.09.2022 05:02
Изучите ниже приведенный рисунок и определите действия, которые выполняет робот из предложенных блоков программы ...
Лебеде
30.04.2021 02:28
по информатике сор 5 класс...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.
б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.
в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.
г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.