В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Сработой. напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; решение тремя

Показать ответ
Ответ:
Асечка05
Асечка05
08.10.2020 14:07
Function getSumFor(n:integer):integer;var sum, i:integer;begin  sum := 0;  for i:=1 to n do   begin    sum := sum + i;  end;  result := sum;end;
function getSumWhile(n:integer):integer;var sum, i:integer;begin  sum := 0;  i := 1;  while i <= n do  begin    sum := sum + i;    i := i + 1;  end;  result := sum;end;
function getSumRepeat(n:integer):integer;var sum, i:integer;begin  i := 1;  sum := 0;  repeat    sum := sum + i;    i := i + 1;  until i > n;  result := sum;end;
begin  writeln(getSumFor(1));  writeln(getSumWhile(1));  writeln(getSumRepeat(1));end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота