В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
derevyaniy02
derevyaniy02
08.12.2021 01:13 •  Информатика

Ұсынылған өрістермен, программалық кодпен таныс және роботтың өткен қызыл, сары және жасыл өрістердің санын анықта.
Қызыл -4 сары -2, жасыл - 1
Қызыл -3, сары - 2, жасыл - 1
Қызыл -4, сары -3, жасыл - 2​

Показать ответ
Ответ:
dianka2712
dianka2712
05.07.2020 20:28

использовать Чертежник

алг

нач

сместиться в точку (2,4)

б

а

о

б

а

б

кон

алг б

нач

опустить перо

сместиться на вектор (-2,0)

сместиться на вектор (0,-4)

сместиться на вектор (2,0)

сместиться на вектор (0,2)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (3,-2)

кон

алг а

нач

опустить перо

сместиться на вектор (0,2)

сместиться на вектор (2,2)

сместиться на вектор (0,-4)

сместиться на вектор (0,1)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (5,3)

кон

алг о

нач

опустить перо

сместиться на вектор (-2,0)

сместиться на вектор (0,-4)

сместиться на вектор (2,0)

сместиться на вектор (0,4)

поднять перо

сместиться на вектор (3,0)

кон

Объяснение:

картинка


Для исполнителя Чертёжник в среде программирования КуМир составьте программу рисования слова БАОБАБ.
0,0(0 оценок)
Ответ:
Lanevskie2004
Lanevskie2004
14.06.2020 01:02

program z1;

var a:array [1..21] of integer;

i,m: integer;

begin;

write('0.');

for i:=1 to 21 do

begin

a[i]:=random(66)-13;

write(a[i]:5)

end;

writeln;

write('1.');

for i:=1 to 21 do

begin

if i mod 2 = 0 then a[i]:=-3*a[i];

write(a[i]:5)

end;

writeln;

write('2.');

for i:=1 to 21 do

begin

if a[i] < 10 then a[i]:=-a[i];

write(a[i]:5)

end;

writeln;

write('3.');

for i:=1 to 21 do

begin

if abs(a[i]) > 40 then a[i]:=a[i]-15;

write(a[i]:5)

end;

writeln;

m:=1;

for i:=1 to 21 do if a[m] < a[i] then m:=i;

a[m]:=m*m;

write('4.');

for i:=1 to 21 do write(a[i]:5)

end.

Объяснение:

После каждого преобразования выводится получившийся массив

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота