В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nikolyaemelyan
nikolyaemelyan
09.12.2022 12:20 •  Информатика

Тема: знакомство с языком паскаль
1 уровень сложности и
1. а) набрать в редакторе системы турбо-паскаль следующую программу:
program my;
var a,b,c,s: integer;
begin
readln(a);
readln(b);
readln(c);
s: =a*b*с;
writeln(s)
end.
6) откомпилировать набранную программу и исправить ошибки.
в) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел 2, 4 и 6.
г) запустить данную программу на выполнение и проверить правильность её рабо-
ты для чисел 1, ои-1.
д) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел -2, зи 10.
2. написать программу, которая присваивает целой переменной а значение 10 и
выводит это значение на экран.
3. написать программу, которая запрашивает ввод целого числа в переменную в и
выводит это число на экран. проверить правильность работы программы на числах 1, -
5, 256, 10455.
4. написать программу, которая запрашивает ввод вещественного числа в пере-

Показать ответ
Ответ:
anelya033
anelya033
23.05.2020 05:30
№1

var sum, i: integer;
begin
sum := 0;
for i := 1 to 100 do
sum := sum + i;
writeln('Сумма всех чисел от 1 до 100: ', sum);
end.

№2

var p, i: integer;
begin
p := 1;
for i := 1 to 10 do p := p * i;
writeln('Произведение всех чисел от 1 до 10: ', p);
end.

№3

У вас не дано никаких условий. Вот задача для условия: "Членов прогрессии - 100, шаг - 3"

var A, i, k, max: integer;
begin
i := 3;
max := 100;
for k := 1 to max do begin
A := A + i;write( A, ' ');
end;
end.

№4

var sum, x: real;
a: array[1..10] of real;
i: integer;
begin
sum := 0;
for i := 1 to 10 do begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;

writeln('Сумма введенных чисел: ', sum);
end.
0,0(0 оценок)
Ответ:
Tamalova5
Tamalova5
11.08.2021 00:02

Объяснение:

Відповідь:

Помилки та причини їх появи на етапах життєвого циклу

Помилка - це стан програми, при якому генеруються неправильні результати. Причиною помилок є недоліки в операторах програми або в технологічному процесі її розроблення, що призводить до неправильного перетворення вхідної інформації у вихідну. Дефект у програмі виникає внаслідок помилок розробника. Він може міститися у вхідних або проектних специфікаціях, текстах кодів програм, в експлуатаційній документації тощо. Відмова - це неможливість виконувати функції, визначені вимогами й обмеженнями. Вона виникає внаслідок таких причин:

o помилкової специфікації або пропущеної вимоги (специфікація точно не відображає припущення користувача);

o наявність вимоги, яку неможливо виконати на цій апаратурі і ПЗ;

o помилки у проекті програми (приміром, базу даних спроектовано без захисту від несанкціонованого доступу користувача, а захист потрібен);

o помилки в алгоритмі.

Помилки у ПЗ можна класифікувати відповідно до їхнього розподілу за етапами життєвого циклу і джерел їхнього виникнення:

1) ненавмисне відхилення розробників від робочих стандартів або планів реалізації;

2) специфікації функціональних та інтерфейсних вимог без дотримання стандартів розроблення;

3) недосконала організація процесу розроблення.

Помилки можуть виникати під час розроблення програмного забезпечення на різних етапах життєвого циклу. Розглянемо детальніше ці етапи.

1. Етап аналізу вимог. У визначенні вхідної концепції системи та опису вхідних вимог замовника виникають помилки аналітиків, коли вони формулюють специфікації верхнього рівня і будують концептуальну модель ПрО.

Характерні помилки:

o неадекватність опису специфікаціям вимог кінцевих користувачів;

o некоректність специфікації взаємодії програмного забезпечення із середовищем функціонування або з користувачами;

o невідповідність вимог замовника окремим і загальним властивостям програмного забезпечення;

o некоректність опису функціональних характеристик;

o незабезпеченість інструментальними засобами підтримки всіх аспектів реалізації вимог замовника тощо.

2. Етап проектування компонент. Помилки під час проектування компонент можуть виникати при описі алгоритмів, логіки управління, структур даних, інтерфейсів, логіки моделювання потоків даних, форматів введення-виведення тощо. В основі цих помилок лежать дефекти специфікацій аналітиків та помилок проектувальників.

Помилки можуть виникати під час:

o визначення інтерфейсу користувача із середовищем;

o опису функцій (неадекватності формулювань у проекті мети та завдань окремих компонентів, що виявляються при перевірці проекту);

o визначення процесу опрацювання інформації або зв'язків між процесами (наслідок некоректного визначення взаємозв'язків компонентів та процесів);

o визначення даних і їх структур для окремих компонент та програмного забезпечення, що в цілому некоректно задані;

o опису алгоритмів модулів та їхньої логіки, що некоректно визначені в поданому проекті модуля;

o визначення умов виникнення можливих помилок у програмі;

o порушення прийнятих для проекту стандартів та технологій

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота