В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
milayakisa1
milayakisa1
04.01.2023 04:02 •  Информатика

только не всё в одной проге, а сразу несколько. составьте хоть две программы, нужно( а. составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с четными значениями б. составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет произведение элементов массива с нечётными значениями в. составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива г. составьте программу которая заполняет массив a[1..10] случайными числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива с четными значениями.

Показать ответ
Ответ:
nastuastar12
nastuastar12
21.06.2020 04:53
1)
var a: array [1..10] of integer;
    i, m: integer;
begin
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 0) then m := m + a[i];
     end;
     writeln(m);
end.

2)
var a: array [1..10] of integer;
    i, m: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 1) then m := m * a[i];
     end;
     writeln(m);
end.

3)
var a: array [1..10] of integer;
    i, m: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          m := m + a[i];
     end;
     writeln(m / 10);
end.

4)
var a: array [1..10] of integer;
    i, m, c: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 0) then
          begin
               m := m + a[i];
               c := c + 1;
          end;
     end;
     if (c > 0) then writeln(m / c);
end.

Вас =)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота