В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Катя46811909
Катя46811909
16.12.2022 00:15 •  Информатика

У вас есть массив чисел длиною "N". Нужно найти XOR всех чисел. Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Выведите XOR всех чисел

Пример 1
Ввод:
10
71 39 83 41 67 55 89 5 45 77

Вывод:
82

Показать ответ
Ответ:
ivan1и2в3а4н5
ivan1и2в3а4н5
14.09.2020 21:16

1.Гиперссылка - это часть документа, ссылающаяся на элемент в этом документе или на другой объект.

Гиперссылки мы находим в практически каждом документе, например:

Научная статья (в ней может находится ссылка на какой-либо другой источник, либо же какой-то другой документ указывает на статью гиперссылку)

Резюме (в нём могут быть ссылки на ваш почтовый ящик, файлы)

Также гиперссылки используются просто в больших документах, где можно создать лист "Оглавление" для быстрого перехода на нужные Вам страницы.

0,0(0 оценок)
Ответ:
ArtSvet
ArtSvet
09.02.2021 21:46
//Я просто опишу метод записи матрицы
const n=100;
var ar:array of array of integer;
 ars:array of array of string;
 i:integer;
 
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
 i,j:integer;
begin;
for i:=1 to n do
 begin;
   for j:=1 to n do
    begin;
     ar[i,j]:=random(9);
     str(ar[i,j],ars[i,j]);
    end;
 end;
end;

procedure burning(ars:array of array of string);
var
 i,j:integer;
 t:text;
 begin;
  assign(t,'text.txt');
  rewrite(t);
  for i:=1 to n do
   begin;
    writeln(t,' ');
     for j:=1 to n do
      write(t,ars[i,j],' ');
   end;
 end;  

begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
 begin;
  setlength(ar[i],n+1);
  setlength(ars[i],n+1);
 end;
complection(ar,ars);
burning(ars);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота