В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
D202
D202
01.04.2020 06:07 •  Информатика

УМОЛЯЮ
задание 1.
Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в ЭВМ, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y. (рисунок снизу)
задание 2.
Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X = (0,3; 5; 69; –3; 52; –20; –9; –23; –9; 10; 36; 12; 15; 23; –0,2; –36; –0,3; 8; 45; –7) при b = –6 Вычислить произведение и количество элементов, не равных нулю и больших b.

задание 3.
Составить программу и блок-схему алгоритма для вычисления площади 5 квадратов со сторонами, изменяющимися от 0 до 15 в цикле.

В отчет включить текст программ на Паскале, реакции ЭВМ.

Показать ответ
Ответ:
Юлия45684
Юлия45684
15.09.2020 11:01

program arrdiap;

var

 N, A, B, i: Integer;

 M: array of Integer;

begin

 Write ('Введите размерность массива: ');

 ReadLn (N);

 SetLength (M, N);

 Randomize;

 for i := Low (M) to High (M) do begin

   M [i] := Random (100);

   Write (M [i], ' ');

 end;

 WriteLn;

 Write ('Введите диапазон A, B: ');

 ReadLn (A, B);

 WriteLn;

 WriteLn ('Принадлежит диапазону ', A, ' - ', B, ':');

 for i := Low (M) to High (M) do begin

   if (M [i] >= A) and (M [i] <= B) then

     Write (M [i], ' ');

 end;

 ReadLn;

end.

0,0(0 оценок)
Ответ:
azhiltsova15ozb142
azhiltsova15ozb142
01.10.2020 15:10

Значит просто расписать как это должно работать?

Объявляем переменную День, которая будет считывать количество дней.

Вводится H хлеба - общее количество и Z - количество, которое потребляется в день.

Переведем кг в г, чтобы легче было считать: H = H * 1000

Запускается цикл пока H > 0(пока хлеб вообще имеется)

один проход цикла - один день, значит в теле цикла H = H - Z

То есть мы вычитаем из общего кг хлеба суточное потребление.

И увеличиваем переменую День на 1.

После этого цикла выводим переменную День.

Приведу пример на языке с++. В случае ввода H = 1, Z = 50, выводится ответ 20 дней

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

int day = 0, Z, N;

cin >> N >> Z;

N = N * 1000;

while(N > 0){

 N = N - Z;

 day++;

}

cout << day << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота