В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
asd135
asd135
06.11.2022 08:15 •  Информатика

В некоторой Меньшей Школе программистов близится время итоговой олимпиады. Всего в ней 30 групп, в каждой из которых учатся от 10 до 30 человек. В олимпиаде принимают участие команды из трех человек. Напишите программу, которая подсчитывает и выводит количество людей в самой большой группе, которую удастся разбить на команды так, чтобы не привлекать учащихся других групп и были задействованы все учащиеся группы. Гарантируется, что хотя бы одна такая группа есть. Формат входных данных
В единственной строке перечислены 30 чисел — количество учеников в каждой группе.

Формат выходных данных
Количество учеников в самой большой группе, где удалось всех разбить на команды. Гарантируется, что ответ существует.

входные данные выходные данные
17 19 23 28 20 22 14 28 13 19 10 15 22 12 17 13 17 19 10 22 13 19 19 27 10 23 29 28 26 25
27
17 14 18 18 20 12 19 18 18 14 10 15 22 12 22 18 17 14 20 17 13 14 19 12 20 13 19 13 21 20
21​

Показать ответ
Ответ:
olgaslizova
olgaslizova
17.09.2022 20:49
#include <iostream>
using namespace std;
int main()
{
    int n, m, c;
    cout << "n = ";
    cin >> n;
    cout << "m = ";
    cin >> m;
    int a[n][m];
    for(int i = 0; i < n; i++)
    {
        cout << "Введите " << i + 1 << " рядок матрицы (" << m << " элементов) через пробел" << endl;
        for(int j = 0; j < m; j++)
        {
            cin >> a[i][j];
            if(a[i][j] % 2 == 1)
            {
                c++;
            }
        }
    }
    cout << "Количество нечетных элементов массива равно " << c;
}

#include <iostream>
using namespace std;
int main()
{
    int n, mi = 0, mj = 0, sum = 0;
    cout << "n = ";
    cin >> n;
    int a[n][n];
    for(int i = 0; i < n; i++)
    {
        cout << "Введите " << i + 1 << " рядок матрицы (" << n << " элементов) через пробел" << endl;
        for(int j = 0; j < n; j++)
        {
            cin >> a[i][j];
            if(a[i][j] < a[mi][mj])
            {
                mi = i;
                mj = j;
            }
        }
    }
    for (int j = 0; j < n; j++) 
   {
        sum += a[mi][j];
    }
    cout << "Сумма элементов рядка с минимальным элементом равна " << sum;
}
0,0(0 оценок)
Ответ:
aneechkaa000
aneechkaa000
25.03.2021 11:44
var
X: array [1..10] of integer;
a,s,i: integer;
begin
randomize;
write('Хотите заполнить массив самостоятельно? (1) Или автоматически? (2)');
readln(s);
case s of
  1: begin
     writeln('Введите 10 элементов массива: ');
     for i:= 1 to 10 do readln(X[i]);
     a:=X[1];
      for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
 2: begin
     writeln('Массив: ');
     for i:= 1 to 10 do
     begin
      X[i]:=random(101);
      write(X[i]:4);
     end;
    writeln;
    a:=X[1];
     for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
  end;
end.     
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота