Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nikita1197
21.09.2022 16:26 •
Информатика
Вмассиве а(10) заменить все отрицательные элементы нулями и массив вывести в строчку. массив в(10) определить в каком массиве положительных элементов больше.
Показать ответ
Ответ:
minnie2
03.07.2020 16:20
Using System;
namespace ConsoleApp {
internal class Program {
private static void Main() {
var a = new int[10];
var b = new int[10];
var positives = new[] {0, 0};
var r = new Random(DateTime.Now.Millisecond);
for (var i = 0; i < a.Length; i++) {
a[i] = r.Next(-100, 100);
b[i] = r.Next(-100, 100);
a[i] = (a[i] < 0) ? 0 : a[i];
positives[0] += (a[i] > 0) ? 1 : 0;
positives[1] += (b[i] > 0) ? 1 : 0;
Console.Write(a[i] + " ");
}
Console.WriteLine();
Console.WriteLine("Больше положительных элементов в массиве {0}", (positives[0] > positives[1]) ? "A" : "B");
Console.ReadKey();
}
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Andrey5454
29.05.2020 06:40
ответьте на вопросы контролиной...
танюха12354
05.08.2020 13:37
дано 16 слов из 6 символов.Если каждый симвор кодируется 1 байтом, то какое минимальное количество бит понадобится для кодирования всех слов?...
sofia3451
16.04.2022 22:04
Паскаль. написать программу для расчёта произведения элементов одномерного массива. (размер массива произвольный, элементы вводятся с клавиатуры)...
maksimsavelev1
26.05.2020 03:21
Паскаль. написать программу для ввода произвольных чисел в одномерный массив. (размер массива произвольный, элементы вводятся с клавиатуры)...
viktoriasvoya
19.06.2022 06:44
Заполни таблицу название и назначение . тема воспроизведение звука икт 3 класс...
Comicsans123
18.01.2023 22:27
сформировать массив элементы которого равныa)13,33,б) 17,16,заранее ❤️...
sagal63
27.09.2022 13:45
4вариант. нельзя прибегать к операции индексации...
Лапушка150
21.03.2020 06:39
Разгодайте код и прочитайте с его пословицу 1,2,3,4,5,1,6 7,8,9,10,11 9,4,7,4,13,12,14...
XxXKotikXxX
21.03.2020 06:39
Задан массив из 10 целых чисел.обменять значениями третий и предпоследний элемент массива....
biksummer23
23.04.2022 08:57
Написать программу на С# для решения следующей задачи: найти наибольший элемент числовой последовательности, вывести его порядковый номер и значение....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
namespace ConsoleApp {
internal class Program {
private static void Main() {
var a = new int[10];
var b = new int[10];
var positives = new[] {0, 0};
var r = new Random(DateTime.Now.Millisecond);
for (var i = 0; i < a.Length; i++) {
a[i] = r.Next(-100, 100);
b[i] = r.Next(-100, 100);
a[i] = (a[i] < 0) ? 0 : a[i];
positives[0] += (a[i] > 0) ? 1 : 0;
positives[1] += (b[i] > 0) ? 1 : 0;
Console.Write(a[i] + " ");
}
Console.WriteLine();
Console.WriteLine("Больше положительных элементов в массиве {0}", (positives[0] > positives[1]) ? "A" : "B");
Console.ReadKey();
}
}
}