В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
merit6052
merit6052
03.02.2022 20:21 •  Информатика

Вмассиве из 20 целых чисел найдите наибольший элемент среди отрицательных и поменяйте его местами с первым элементом. вот начал делать, а потом не знаю как дальше: const k=20; var a: array[1..k] of integer; g,i,max: =integer; begin for i: =1 to n do begin a[i]: =random(20)-10; write(a[i],' '); max: =a[i]; for i: =1 to n do if a[i]< 0 then max: =a[i]; writeln('max=',max); end; дальше не знаю, там по-моему надо ввести переменную (в моём случае "g") и мне кажется там ошибка в поиске максимально среди отрицательных элементов. .

Показать ответ
Ответ:
64bl9j8
64bl9j8
23.06.2020 16:48
Var 
a:array[1..20] of integer;
i,max,c,nom:integer;
begin
max:=-100000000;
for i:=1 to 20 do begin
a[i]:=random(20)-10;
write(a[i],' ');
end;
for i:=1 to 20 do begin
if (a[i]<0) and  (a[i]>max) then  nom:=i;
if (a[i]<0) and  (a[i]>max) then max:=a[i];
end;
writeln;
for i:=1 to 20 do begin
if i=nom then swap(a[nom],a[1]);
end;
for i:=1 to 20 do begin
write(a[i],' ');
end;
writeln('max=',max,');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота