В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
IbraevaLisa
IbraevaLisa
19.12.2022 03:08 •  Информатика

Во Free Pascal составьте программу вычисления арифметического выражения y=x^2 - 7x, если x<0, либо y= 10 + 5x, если

Показать ответ
Ответ:
50АлисА05
50АлисА05
04.09.2020 12:12
Почему?

Потому что Вы каждый раз, когда матрица симметрична (но не до конца, а на данной итерации), выводите "YES", хотя не знаете, будет ли она симметрична далее.

Как решить?

1. Заведите переменную типа bool:

bool isSymmetrically = true;

2. В теле условия if (a[i][j] != a[j][i]) замените вывод на следующее:

isSymmetrically = false; // матрица не симметрична, можно заканчивать цикл (с

В блоке else:

isSymmetrically = true; // на данном этапе симметрия присутствует

2.1. После вложенного цикла произведите проверку на то, симметрична ли матрица, чтобы в случае несимметричности не продолжать проверку, а сразу сделать вывод:

if (isSymmetrically == false)

{  break;  }

3. После всех циклов вы произвдите следующую проверку:

if (isSymmetrically = true) // если матрица симметрична

{ // вывод YES }

else

{ // вывод NO }

Исправленный код#include <iostream>using namespace std;int main(){    int n = 0;    int a[100][100];    bool isSymmetrically = true;    cin >> n;    for (int i = 0; i < n; i++)    {        for (int j = 0; j < n; j++)        {            cin >> a[i][j];        }        cout << endl;    }    for(int i = 0; i < n - 1; i++)    {        for(int j = i + 1; j < n; j++)        {            if(a[i][j] != a[j][i])            {                isSymmetrically = false;                break;            }            else            {                isSymmetrically = true;            }        }        if (isSymmetrically == false)        {          break;        }    }    if (isSymmetrically == true)    {        cout << "YES" << endl;    }    else    {        cout << "NO" << endl;    }    return 0;}
0,0(0 оценок)
Ответ:
Natalym2001
Natalym2001
26.11.2021 07:34

7

Объяснение:

Алгоритмы устойчивой сортировки :

Сортировка пузырьком (англ. Bubble sort) — для каждой пары индексов производится обмен, если элементы расположены не по порядку. Сложность алгоритма:

Сортировка перемешиванием (англ. Cocktail sort). Сложность алгоритма:

Сортировка вставками (англ. Insertion sort) — определяем, где текущий элемент должен находиться в упорядоченном списке, и вставляем его туда. Сложность алгоритма:

Гномья сортировка (англ. Gnome sort; первоначально опубликована под названием «глупая сортировка» [stupid sort] за простоту реализации) — сходна с сортировкой вставками. Сложность алгоритма рекурсивная версия требует дополнительно {\displaystyle  памяти.

Сортировка слиянием (англ. Merge sort) — выстраиваем первую и вторую половину списка отдельно, а затем объединяем упорядоченные списки. Сложность алгоритма: . Требуется  дополнительной памяти.

Сортировка с двоичного дерева (англ. Tree sort). Сложность алгоритма:  в лучшем случае, a в худшем. Требуется O(n) дополнительной памяти.

Сортировка Timsort (англ. Timsort) — комбинированный алгоритм (используется сортировка вставками и сортировка слиянием). Сложность алгоритма. Требуется дополнительной памяти. Разработан для использования в языке Python.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота