Впитоне (python). 20 .
напишите программу, которая открывает этот файл на чтение, построчно считывает из него данные и записывает строки в другой файл, заменяя числительные , которые содержатся в списке (["один", "два", "три", "четыре", "пять" определенном до открытия файлов.
буду .
1) Блокнот: Простой текстовый редактор Windows. Просто для текста. Удобен как очень быстрое место для записи заметок
WordPad: Редактирование и создание документов, таких как DOCX, ODT-и так далее.
2) Блокнот: С Блокнота можно открывать файлы с расширениями LOG, INF, INI, а так же сохранять их в разных кодировках (Юникод, UTF-8, ANSI)
WordPad: Так же может открыть TXT, ODT, DOCX и готов их сохранить.
3) Блокнот: Настраивается, по умолчанию переноса нет.
WordPad: Так же настраивается, можно установить переключатель Перенос по словам (Word Wrap).
4) Доступна и в блокноте и в WordPad.
5) Доступна у блокнота и WordPad, горячая клавиша - CTRL + Z
6) У двух редакторов одни и те же горячие клавиши - CTRL + X, CTRL + C, CTRL + V, DEL
7) Блокнот не поддерживает, если только системно его не изменить. WordPad может форматировать текст, изменять шрифт.
8) Блокнот не поддерживает, WordPad поддерживает данный функционал.
9) Насчёт блокнота точно не скажу, но WordPad есть данный функционал.
10) Блокнот поддерживает, так же как и WordPad.
11) И то и другое - предоставляет данный функционал.
12) Точно не знаю, но в блокноте вроде бы такого нет, так же как и у WordPad. Но я не уверен.
13) И то и другое - можно распечатать.
14) Блокнот не поддерживает объекты, а WordPad - есть такой функционал.
15) Не совсем понял вопрос.
Объяснение:
Надеюсь, я правильно понял задачу.
// PascalABC.Net 3.0, сборка 1066
var
s,s1:string;
i:integer;
a:char;
begin
Write('Введите натуральное число любой длины :'); Readln(s);
Write('Введите цифру, которую надо удалить: '); Readln(a);
s1:='';
for i:=1 to Length(s) do
if s[i]<>a then s1:=s1+s[i];
Writeln('Результат: ',s1)
end.
Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793
2. Современное решение (так в школе почему-то не учат)
// PascalABC.Net 3.0, сборка 1066
begin
var s:=ReadString('Введите натуральное число любой длины :');
var a:=ReadChar('Введите цифру, которую надо удалить: ');
Write('Результат: ',s.Replace(a,''));
end.