В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rayanova81
rayanova81
06.11.2021 11:45 •  Информатика

ВСЕ ОТДАЮ Сколько единиц будет в списке A

после выполнения такой программы:

A = []
for i in range(5):
A.append(i)
A = A * 2
A = A * 100

Показать ответ
Ответ:
Айхан1111111
Айхан1111111
10.07.2021 13:46
1. Надо добавить точку в последней строке программы. Иначе работать не будет.
2. Меняется всего одна строка в программе:

program pr2;

type
  student = record {объявление нового типа данных student}
    LastName: string; {фамилия студента}
    bal: array [1..5] of integer; {массив для 5-ти оценок}
    average: real {средний студента}
  end;

var
  pupil: array [1..100] of student; {массив pupil (максимум из 100 элементов) типа student}
  n, i, j, s: integer;{переменные целого типа}

begin
  write('Введите количество студентов: ');
  readln(n);
  for i := 1 to n do
  begin{запрос данных по n студентам}
    with pupil[i] do
    begin
      Write('Введите фамилию студента №', i, ': '); {запрос фамилии студента под номером i}
      Readln(LastName);
      s := 0; {целочисленная переменная для определения суммы студента}
      for j := 1 to 5 do
      begin{цикл для обработки 5-ти оценок каждого студента}
        write('Введите оценку за экзамен №:', j, ': ' );
        readln(bal[j] );
        s := s + bal[j]; {суммирование 5-ти оценок студента}
      end;
      average := s / 5; {определение среднего значения и запись в переменную average}
    end;
  end;
  writeln;
  writeln( 'Студенты, имеющие средний больший или равный 4');
  for i := 1 to n do
  begin
    if pupil[i].average >= 4 then {если средний студента >=4}
    write(pupil[i].LastName,', ');
  end;
end.
0,0(0 оценок)
Ответ:
marinafrolkovap09wnn
marinafrolkovap09wnn
10.07.2021 13:46
В запись student добавляете новое поле kurs,
Type student = recordLastName: string ; bal: array [1..5] of integer; 
kurs: integer;average: real end;
В цикле по студентам добавляете ввод курса
with pupil[i] do begin
Write ('Введите фамилию студента №', i ,': '); 
Readln (LastName);
 Write('Введите курс '); Readln(kurs);
В конце программы изменяете вывод
writeln ( 'Студенты первокурсники, имеющие средний больший или равный 4');
For i:=1 to n do beginif (pupil[i].average >=4) and (pupil[i].kurs = 1) then 
write (pupil[i].LastName,',  ');
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота