В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Katerinkacat
Katerinkacat
07.06.2023 16:12 •  Информатика

Вшколе n учеников 9 класса писали пробный экзамен по . составить программу, подсчета количества 2,3,4,5, полученных за экзамен. считайте оценку ученика случайным числом из диапазона от 2 до 5.

Показать ответ
Ответ:
Сахарокcom
Сахарокcom
07.10.2020 13:44
Var
  A: array[1..200] of byte;
  i, N, cTwo, cThree, cFour, cFive: byte;
begin
write('Введите количество учеников(N): '); readln(N);
randomize;
writeln('Все оценки за экзамен.');
for i := 1 to N do
begin
  A[i] := random(4)+2;
  if A[i] = 2 then cTwo := cTwo + 1;
  if A[i] = 3 then cThree := cThree + 1;
  if A[i] = 4 then cFour := cFour + 1;
  if A[i] = 5 then cFive := cFive + 1;
  write(A[i], ' ');  
end;
writeln('');
writeln('Оценку 2 получили ', cTwo, ' уч.');
writeln('Оценку 3 получили ', cThree, ' уч.');
writeln('Оценку 4 получили ', cFour, ' уч.');
writeln('Оценку 5 получили ', cFive, ' уч.');
writeln;
end.

Вшколе n учеников 9 класса писали пробный экзамен по . составить программу, подсчета количества 2,3,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота