Выполнить задание. Составить программу заполнения массива по следующему принципу:
0 1 1 1 0
1 0 1 0 1
1 1 0 1 1
1 0 1 0 1
0 1 1 1 0
Задание 1. Дан массив 10 целых чисел. Найти произведение чисел.
Задание 2. Дан массив из 20 целых чисел. Все элементы меньшие 10 заменить на 0 и вывести полученный массив на экран.
var a, b, с: integer;
begin
write('Введите два числа: ');
readln(a, b);
if a < b then с := a + 1 else с := b + 1;
repeat с := с - 1
until (a mod с = 0) and (b mod с = 0);
write('NOD = ', с)
end.
//2. Алгоритм с вычитанием (цикл while)
var a, b: integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
while a <> b do
if a > b then
a := a - b
else
b := b - a;
writeln('NOD = ', a);
end.