В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
turebekrasul
turebekrasul
25.10.2020 04:24 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить координаты двух точек на плоскости. (координаты целочисленые) и выводит на экран расстояние между ними.

Показать ответ
Ответ:
Франц11
Франц11
03.03.2021 21:28

program  z1;

var xa,ya,xb,yb:integer;

begin

write('Введите координаты первой точки: ');

read(xa,ya);

writeln('Введите координаты второй точки: ');

read(xb,yb);

writeln('Расстояние между точками равно: ',sqrt(sqr(xb-xa)+sqr(yb-ya)):0:3);

end.

Объяснение:

Расстояние между двумя точками A(xa, ya) и B(xb, yb) на плоскости:

AB = \sqrt{(xb - xa)^{2} + (yb - ya)^{2}}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота