В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SAHARIA
SAHARIA
03.02.2023 19:05 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 5-значное число и определять, является ли число палиндромом. Палиндром — число (или слово), которое
одинаково "читается" слева направо и справа налево. Например, число 12321 –
палиндром, а число 12345 — нет.
На вход программы подаётся 5-значное натуральное число (проверку корректности ввода
проводить не надо), на выходе должно появиться одно слово - Yes, если число является
палиндромом, и No, если нет.
Вспомните разговор о типах данных! В этой задаче число 5-значное, оно может быть
больше 32767. В некоторых версиях Pascal такое число не может быть описано как
integer. Поэтому для корректной работы программы входное число следует описать
Kax longint.​


Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 5-значное число и определять

Показать ответ
Ответ:
тучя
тучя
29.04.2021 10:51

всё ещё проще. будем считать число строкой символов. И если первый и последний и второй и предпоследний символы равны - то это и будет палиндром. Прикольно что это будет работать и со строковыми данными - словами   :))

Объяснение:

var

 s : string;

begin

 readln(s);

 writeln('');

 if (s[1]=s[5]) and (s[2]=s[4]) then

   writeln('Yes')

 else

   writeln('no')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота