В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nastaklimenkofll
nastaklimenkofll
16.03.2021 11:51 •  Информатика

Язык программирования Paython Напишите программу, которая решает следующую задачу.

Ввести контрольное число k. Запрашивать натуральное число n и

распечатывать его куб до тех пор, пока число не станет равно k. Если
число будет равно k, то вывести сообщение о том, что подсчет окончен.
Ввод чисел выполните с пояснением. Вывод результата выполните с
пояснением.

Показать ответ
Ответ:
max50chepil
max50chepil
24.11.2020 08:12
Зеркальный 2,5 м телескоп
Оснащен пятью портами (1 фокус Кассегрена и 4 фокуса Несмита) с возможностью автоматического оперативного переключения. Планируемый список навесного оборудования:

ПЗС-фотометр (4k × 4k ПЗС-камера на основе 2 приёмников E2V CCD44-82 производства института Н. Бора с фильтрами (UBVRI, SDSS и узкополосные) для видимого диапазона
ИК-камера-спектрометр (ИК-детектор с рабочим полем 1k × 1k), фильтры J, H, Ks, K, Fe, Methane; гризмы с R~1500 с кросс-дисперсией
Спекл-камера на основе EMCCD
Оптический спектрограф низкого разрешения
Оптико-волоконный спектрограф высокого разрешения
0,0(0 оценок)
Ответ:
vladamalaxova
vladamalaxova
14.02.2023 00:43

#include <iostream>

#include <ctime>

#include <algorithm>

signed main() {

 

setlocale(LC_ALL, "Rus");

srand(time(NULL));

 

int n;

std::cout << "Размер массива: ";

std::cin >> n;

int* arr = new int[n];

std::cout << "Исходный массив: ";

for (int i = 0; i < n; i++) {

 arr[i] = rand() % 10;

 std::cout << arr[i] << " ";

}

for (int i = 0; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (arr[j] > arr[j + 1])

   std::swap(arr[j], arr[j + 1]);

 }

}

std::cout << std::endl << arr[n - 1] + arr[n - 2];

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота